Back to overview
Downtime

Some services are down

Nov 24 at 04:58pm EET
Affected services
https://krisjanis.lejejs.com

Resolved
Jan 02 at 11:49am EET

The page is back up, but it does not contain any content yet.

Updated
Nov 25 at 06:56pm EET

Total server crash and 100% data loss.

Created
Nov 24 at 04:58pm EET